Kodları lütfen aşağıdaki butonları kullanarak renklendirin. Örnek: <php> echo "Selam Dünya"; </php>
Yardım
karakter kaldı

Jquery 1.4.2 versiyonu ile çalışan uygulama 1.6.4 versiyonu ile çalışmıyor!

<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js'></script>

sürümü ile
$(this).find('a').attr('title')

şeklinde
<a title='deneme'></a>


sorunsuz alıyorum.

ancak,
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js'></script>

$(this).find('a').attr('title')

şeklinde veri alamıyorum.
Daha doğrusu veri geliyor ancak
$('.class').eq(0).hover();

şeklinde ilk class içindeki aktif olmuyor ancak fare ile üstüne gelince o veride çalışıyor.

1.4.2 ile 1.6.4 arasında bazı farklar var.
http://www.kodaman.org/yazi/jquery-1-6-ve-getirdigi
tahminim attr ile ilgili bir sorun var.
Ancak neden ilk veriyi default olarak getirmeme sebebini anlamış değilim.
Acaba nerde atlıyorum.
+0
-0
Cevaba KatılıyorumKatılmıyorum
Cevap Yaz Yorum Yaz Arşivime Ekle Takip Et

Cevaplar

  • uls adlı üyenin fotoğrafı
    10 yıl önce yazılmış
    65 cevap - 10 soru
    Bu kod bende problemsiz çalışıyor.
    <script src='https://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js'></script>
    <a title="deneme"></a>
    <script> alert($(document).find('a').attr('title')); </script>
    


    Direkt kodları paylaşırsan daha net cevap verilebilir.
    • zyber adlı üyenin fotoğrafı zyber
      http://www.2shared.com/file/HJOfdJRW/ornek.html
      yukarıdaki linke örnek 2 dosya hazırladım.
      Aynı kodlar var sadece jquery dosya sürümleri farklı biri 1.6.4 yani son sürüm diğeri ise 1.4.2 sürümü.

      normal çalışma şekli şu şekilde

      3 link var ve 3 resim var.
      hangi link üstüne fare ilegelirseniz o linkin resmi görünüyor.
      Ancak sayfa ilk açıldığında 1. linkin resmi gösteriliyor. ... eq(0).hover();

      Problemde burada başlıyor.
      1.4.2 sürümü ile çalışan kod ilk çalıştığında 1. resim ayarlı olduğu gibi görünür olarak sayfa açılıyor.

      1.6.4 sürümü ile çalışan kod ise ilk çalıştığında 1. resim görünmüyor fare ile üstüne gidilen resim çalışıyor....

      tüm kodlar aynı sadece jquery versiyonu farklı peki yeni sürümde neden ilk açıldığında 1. linkteki resim görüntülenmiyor?

      http://i55.tinypic.com/20115z6.jpg
      10 yıl önce yazılmış